Saturday, August 8, 2009

Windows 7 (RC, RTM) and static disk activity (about a minute of pause)


I was running into this problem since i got the RC build of Windows 7. I didn’t much bother as i was patient enough to wait till things started to work again (which eventually it does) and also figured it may be fixed by the time RTM is out.
Well, that isn’t the case, now, i am on the official RTM build (and 64bit) and it still choked every once in a while (similar to what i had on an RC 32bit).
Symptom.
Every other time, the disk activity on my SATA disk on my cheapo Dell Inspiron 1525 kept a static blink like a contiguous disk activity or as though there was a hardware failure on the disk. This causes certain newly launched apps or older ones which are running to freeze momentarily for almost about 30 seconds to 1 minute. This problem didn’t appear when i used Ubuntu 9.04 on this same exact system.
Solution
Well i found the problem (or more like the solution). It was the AHCI setting in my BIOS that causes this to happen (well, when i turned it to ATA mode, this problem didn’t crop up). This is also related to an older SATA HDD i inserted into my new Dell (the older SATA disk had higher RPM so i decided to use that instead)
SO if you get this annoying problem every once in a while, load up your BIOS, go to your SATA disk configuration and turn off AHCI and turn off flash cache (this is required according to the BIOS setting when you turn of AHCI.
Now, i am at peace :)
(NOTE: Some OSes including 7 BETA will not boot well according some internet searching i did) so, if things break, read next line.)
Use Ubuntu.

Thanks to my colleague Feroz Khan for the idea and this little snippet below from the WIKI link on AHCI above.
Post a Comment